Универсальный отчет по произвольному регистру за произвольные периоды.




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2018-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

35 Comments

  1. Misha_J

    Отследили глюк — неправильно сортирует тб.Запрос не определены колонки…

    вот код:

    Код
    Пока тбЗапрос.ПолучитьСтроку()=1 Цикл
       Для кл=1 По КвоИзмерений Цикл
          ПредЗнач=тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки,кл);
             Если (ПустоеЗначение(ПредЗнач)=1) Тогда
                Если (кл=1)и(тбЗапрос.НомерСтроки<>1) Тогда
                   тбЗапрос.УстановитьЗначение(тбЗапрос.НомерСтроки,кл,тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки-1,кл));
                Иначе
                   тбЗапрос.УстановитьЗначение(тбЗапрос.НомерСтроки,кл,тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки,кл-1));
                КонецЕсли;
             КонецЕсли;
          КонецЦикла;
          Для кл2=НачКолСум По КонКолСум Цикл
             ПредЗнач=тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки,кл2);
             Если ПустоеЗначение(ПредЗнач)=1 Тогда
                тбЗапрос.УстановитьЗначение(тбЗапрос.НомерСтроки,кл2,0);
             КонецЕсли;
          КонецЦикла;
       КонецЦикла;
    тбЗапрос.Свернуть(КолГруппировок,КолСум);
    

    Показать полностью

    Получается тбЗапрос.Свернуть(1,2,3,3,4,5,6);

    Reply
  2. Misha_J

    Получается тбЗапрос.Свернуть(1,2,3,4,5,6);

    Reply
  3. Misha_J

    извеняюсь вот код:

    Код
    КолГруппировок = "";
    Для колГ=1 По КвоИзмерений Цикл
       КолГруппировок = КолГруппировок + колГ;
       Если колГ<КвоИзмерений Тогда
          КолГруппировок = КолГруппировок + ",";
       КонецЕсли;
    КонецЦикла;
    КолСум = "";НачКолСум = КвоИзмерений + 1;КонКолСум = тбЗапрос.КоличествоКолонок();
    Для кСум=НачКолСум По КонКолСум Цикл
       КолСум = КолСум + кСум;
       Если кСум<тбЗапрос.КоличествоКолонок() Тогда
          КолСум = КолСум + ",";
       КонецЕсли;
    КонецЦикла;
    

    Показать полностью

    Reply
  4. Misha_J

    Исправил механизм рекурсии, добавил сортировку по столбцам.

    Reply
  5. vasilykushnir

    Ну что поддержим товарища? Хотя бы за старания — по-моему подобного не встречал.

    Reply
  6. Misha_J

    Кому нибудь пригодилось?

    Reply
  7. poppy

    ИМХО.

    На универсальность этот отчет явно не тянет.

    Единственный его плюс = это разворачивание разных периодов вправо.

    Но, сразу много больших минусов.

    Настраивать эти призольные периоды крайне неудобно.

    По кнопке «Настрйка» все предыдущие насройки теряются. А если учесть, что настривать неудобно, сложно и долго, то это офигенно неприятно.

    По кнопке «Обновить» происход черт знает что. Но не то, что обычно, в типовых конфигурациях.

    Однозначно = нИзачОт.

    Reply
  8. Misha_J

    по поводу настройки произвольных периодов. выбирается период в окне «Период» и нажать кнопку «добавить период». это, конечно же очень сложно и трудно, впрочем как и выбор самого периода… с кнопкой «обновить» действительно недоработка, спасибо что указал.

    Reply
  9. Misha_J

    Исправил «Обновить» и «Настройка»

    Reply
  10. Misha_J

    Группа «Фильтры» создана специально для нашей базы. Кому не надо, может не использовать. Кому интересно, могу рассказать по подробнее…

    Reply
  11. quick

    Пригодилось 🙂

    Reply
  12. vasilykushnir

    Ты прислушайся, прислушайся к poppy — она всегда очень дельные советы дает (прям как требовательный учитель). Иногда просто удивляет ее способность (или настойчивость) ковырятся в чужих разработках. И это, заметь, абсолютно по доброте душевной, чтобы подтолкнуть автора к написанию чего-то путного. При тексте обработки более одной страницы, мне лично уже становится скучно и легче свое написать, чем разбираться в чужом (лень, батенька….)

    Reply
  13. Misha_J

    Вот блин, я думал, что это мальчик…

    Reply
  14. Abadonna

    Poppy всегда права! (как и я 😉 )

    Reply
  15. vasilykushnir

    (13) и сильно растроился?

    (14) Добавлю уточнение: если они не правы — читайте (14)

    Reply
  16. Abadonna

    (15) врожденная скромность помешала мне сделать циклическую ссылку 😉

    Reply
  17. poppy

    (16)

    Программер чистой воды! 😉

    Reply
  18. Misha_J

    это лесть или издивательство?

    Reply
  19. vasilykushnir

    Не знаю что, но не издевательство — это точно. Просто небольшая расслабуха…

    Reply
  20. Abadonna

    Шуткуем мы, не обижайся 😉

    Reply
  21. Abadonna

    (18) И, кстати, 17 — это она про меня 😉

    Reply
  22. Misha_J

    а…, тогда все стало на свои места 🙂

    Reply
  23. Abadonna

    (22) +1 за необидчивость и улыбчивость

    Reply
  24. poppy

    (21)… (23)

    Мальчики… Я вас люблю 😉

    Reply
  25. vasilykushnir

    (24) А вот это дорого стоит…

    Reply
  26. Misha_J

    Чего-то никто больше не делится впечатлениями.

    Reply
  27. Tasselhof

    Отличный отчет! Реально помог!

    Вот только плохо что не выделяется шрифтом/цветом группы =(

    Не удобно смотреть =(

    Например отчет по складу — сливается номенклатура со складом и документом. Все одного шрифта и цвета.

    Reply
  28. Бестия

    Суперский отчетик….

    Reply
  29. andrux

    сдорово

    Reply
  30. p1l1gr1m

    Этот отчет, как и все другие, просто выплёвывает то, что даёт запрос к регистру. Но по моему это должно выглядеть иначе совершенно, т.е. структура должна быть у отчета движений и остатков другая. Интерфейс хромает. Но все равно, автор старался, поэтому молодец!

    Reply
  31. kitt

    (30) Тем не менее, это лучший из универсальных отчетов по регистру, который я знаю. Хотя бы за возможность выводить измерения с типом иерерахический справочник без групп. С некоторыми частями интерфейса конечно туговато (я например так и не понял как сделать группировку по документу, она у меня появляется время от времени, когда я тыкаю во все кнопки подряд:) ). А насчет того что просто выплевывает, не согласен — у меня показывает как раз нормально, если правильно указать расположение группировок. Попропуйте поразбираться еще 🙂

    Reply
  32. kalleka

    я тут кстати похожую разработку выложил… Может кто даст рекомендаций, по улучшению, интерес чисто «академический» — время от времени появляется свободное время на работе

    http://infostart.ru/projects/3581/

    Reply
  33. Креатив

    Скачал, отчёт интересный. Только у меня по регистру остатков в разрезе документов движения остатки-то нулевые :-((

    Reply
  34. v.l.

    (33) Странно, чего нулевые? У меня работает 😉

    Reply
  35. gull22

    Спасибо за обработку, пригодилось

    Reply

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *