Бухгалтерия предприятия редакция 3.0: обновление на 3.0.67.38 (из серии — никогда такого не было, и вот опять). Отключение расширений




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2026-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

14 Comments

  1. alfanika

    А что будет если в расширение добавлены реквизиты? Данные сохраняться? Как тревожно(((

    Reply ↓
  2. capitan

    (1)Оно же не удаляется — а отключается.

    У меня по крайней мере не стерлись.

    Но никто не отменял — попробовать в копии.

    Reply ↓
  3. Aliya12345

    Мы сделали следующим образом.

    в Конфигураторе выгрузили Расширение в файл. Удалили расширение. Обновились. Потом добавили расширение из файла.

    Reply ↓
  4. as-lubava

    Ситуация повторяется не только при обновлении, но и при попытке записать Профиль групп доступа или Права пользователя использующий такой профиль. Обработка решает такие ситуации. Спасибо! Плюс!

    Reply ↓
  5. capitan

    (4) Спасибо )

    Reply ↓
  6. demaxxx

    Столкнулся с ошибкой, после обновления БП.

    Вы пишите:

    Отключаем расширения в базе 1С, обновляемся, включаем расширения.

    Для тех кому лень это делать вручную — прилагаются обработки отключения и включения.

    Их можно вставить в свои скрипты обновления.

    Можно конкретнее, отключить в вашем понимании — это в конфигураторе снять галку «активно», или полностью удалить его из конфигурации?

    Галку «активно» снимал, ошибка наблюдается.

    Reply ↓
  7. capitan

    отключить в любом понимании — это в конфигураторе снять галку «активно»

    если полностью удалить его из конфигурации то удалятся например регистры и т.п. что хранилось в расширении

    Reply ↓
  8. demaxxx

    Подскажите, как действовать.

    При подключении обработки «Обновить таблицы групп доступа» через дополнительные обработки в БП 3.0.67.67 ошибка

    Невозможно подключить дополнительную обработку из файла.

    Возможно, она не подходит для этой версии программы.

    Техническая информация:

    Метод объекта не обнаружен (СведенияОВнешнейОбработке)

    Если попытаться открыть через файл — открыть)

    {ОбщийМодуль.УправлениеДоступомСлужебный.Модуль(5926)}: Ошибка при установке значения атрибута контекста (Значение)

    ЭлементОтбора.Значение = ЗначениеОтбора;

    по причине:

    Неверный тип значения
    Reply ↓
  9. capitan

    (8)Попробуйте вот это расширение подключить.

    У вас должно все пройти и потом сразу удаляйте его.

    https://dropmefiles.com/gU4Ji

    Reply ↓
  10. demaxxx

    (9) Пробуем адаптицию , наблюдается такое поведение:

    1. Адаптация не добавляется, если активно наше расширение (с которым проблемы). скрин https://prnt.sc/mdloyx

    Чтобы обойти ошибку — Отключил наше, добавил адаптацию. Включил своё расширение. Теперь оба активны

    2. Пробуем открыть обработку, получаем ошибку.

    Пробуем открыть обработку через файл-открыть, открывается пустая форма + ошибка

    {ОбновлениеНА3.0.67.38 ОбщийМодуль.УправлениеДоступомСлужебный.Модуль(5)}: Ошибка при установке значения атрибута контекста (Значение): Неверный тип значения

    http://prntscr.com/mdlnxg

    Повторные попытки подключить обработку показывают пустую форму без ошибок.

    *База на SQL, но и на файловом варианте идентичное поведение

    Reply ↓
  11. pipec

    Добрый день! Просьба помочь, мне обработка Обновить таблицы групп доступа для подключенных расширений.epf не помогла (делал все как описано выше). При добавлений пользователю прав в режиме предприятия выходит ошибка записи и не дает записать пользователя (см. скан) и такая же ошибка при открытий обработки (файл — открыть). Информация о релизе в скане.

    для информации:

    База успешно обновлена с расширениями, есть роль в расширений.

    Reply ↓
  12. capitan

    (11)А что вы хотели с ником пипец ? )

    Reply ↓
  13. pipec

    (12) хочу решить проблему) не могу в режиме предприятия добавить права пользователю, по кнопке записать выходит ошибка описанная выше

    Reply ↓
  14. capitan

    (13)На самом деле видел такую проблему у кого то.

    Они просто перед редактированием пользователей расширение отключали )

    Но я подозреваю — это дело еще и в ваших расширениях, попробуйте в них роли обновить из основной конфигурации

    Reply ↓

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *