Обнуление остатков регистров бухгалтерии и накопления




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2026-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

30 Comments

  1. Synoecium

    Судя по описанию, проделана большая работа, странно что мало скачек и плюсов.

    Reply ↓
  2. morozov.sv

    (1) Когда занимался ее разработкой — тоже думал, что будет востребована. Видимо ошибся

    Reply ↓
  3. Agema

    Вс еще впереди! Если универсальная, будет востребована. Проверить бы на госучреждениях…

    Reply ↓
  4. Vladisa

    давно такая нужна была! в УПП подобной я постоянно пользовалась.

    Надо качать!

    Reply ↓
  5. igozakh

    Чем отличаются обработки за 2 и 5 SM?

    Reply ↓
  6. morozov.sv

    (5) Ничем. Вы сами можете выбрать цену

    Reply ↓
  7. igozakh

    Спасибо!

    Reply ↓
  8. Vladisa

    скачали, потестировали, пока все нравится!!! Спасибо автору!

    Reply ↓
  9. merlin1975

    Интересная обработка, но только в ЗУП 3.0 для Беларуси нет документа «Корректировка записей регистров»….

    Reply ↓
  10. morozov.sv

    (9) В конфигурации для Беларуси не тестировал. Проверял в ЗУП 3.1 для России. Скорее всего заработает и у Вас. Вместо «Корректировки записей регистров» там документ «Перенос данных». Подробнее написал в личку

    Reply ↓
  11. morozov.sv

    (10) Проверил. В конфигурации «Зарплата и управление персоналом для Беларуси» (3.0.10.109) работает хорошо

    Reply ↓
  12. Хегга

    В ERP2 не заработало. И это очень, очень грустно.

    Платформа 1С:Предприятие 8.3 (8.3.12.1714)

    Конфигурация 1С:ERP Управление предприятием 2 (2.4.6.160)

    Серверная

    ошибка:

    {ВнешняяОбработка.ОбнулениеОстатков.Форма.ФормаУпр.Форма(1778)}: Ошибка при вызове метода контекста (Удалить)

    ПроверяемыеРеквизиты.Удалить(ПроверяемыеРеквизиты.Найти(«ОбнуляемыйСчет»));

    по причине:

    Несоответствие типов (параметр номер ‘1’)

    Reply ↓
  13. morozov.sv

    (12) Доброе утро! На этом релизе ERP обработку еще не запускал. Попробую повторить и исправить

    Reply ↓
  14. Хегга

    (13)

    Свободные остатки

    Себестоимость товаров

    Товары на складах

    Товары организаций

    Reply ↓
  15. Хегга

    (14)

    Автор поправил обработку. В версии 2.3 проблемы нет.

    Reply ↓
  16. ital

    что то в БП 3.0.67.38 при открытии пишет «Нарушение прав доступа», хотя права полные стоят.

    Reply ↓
  17. morozov.sv

    (16) С проблемой разобрались: пользователю не хватало роли «Открытие внешних отчетов и обработок»

    Reply ↓
  18. smooth

    только за одно описание жирный +

    Reply ↓
  19. SVGS

    Обработка великолепна. Замечательное описание, все удобно, все продумано.

    И в БП 3.0, и в ЗУП 3.1 отработала на 5+ !

    Большое СПАСИБО !!!

    Reply ↓
  20. kleorn

    (6) Добавь еще 10SM, и тогда по законам маркетинга, скачиваний на 5SM увеличится

    Reply ↓
  21. romandvin

    Зря потраченные $M, на бухгалтерии 2.0 корп, последний типовой релиз не работает совсем никак, при закрытии любого счёта выдает ошибку ГЛЧего-тоТам() и ничего не закрывает. Спасибо Автору ).

    Reply ↓
  22. morozov.sv

    (21) Проверил работу обработки на конфигурации «Бухгалтерия предприятия КОРП» (версия 2.0.66.72), но к сожалению, воспроизвести ошибку не удалось. Подробнее написал в личном сообщении

    Reply ↓
  23. CAIN

    На бухгалтерии гос. учреждения 1.0 не работает?

    Reply ↓
  24. morozov.sv

    (23) Работает, но т.к. это система со старым интерфейсом — есть ограничение:

    Нельзя подключить как внешнюю обработку. Для работы необходимо встроить в конфигурацию (рекомендуется) или открывать через «Файл» — «Открыть», запустив систему в управляемом интерфейсе.
    Reply ↓
  25. CAIN

    (24) спасибо

    Reply ↓
  26. Castlevania

    В Бухгалтерии 2.0 не работает. Очень жаль потраченных средств.

    Ошибка инициализации модуля: ОбщийМодуль.ОбщегоНазначения.Модуль

    по причине:

    {ОбщийМодуль.ОбщегоНазначения.Модуль(4368,7)}: Процедура или функция с указанным именем не определена (глЗначениеПеременной)

    Если <<?>>глЗначениеПеременной(«ИспользоватьУправляемыеБлокировки») Тогда

    {ОбщийМодуль.ОбщегоНазначения.Модуль(6145,76)}: Процедура или функция с указанным именем не определена (глЗначениеПеременной)

    НайденноеЗначение = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(<<?>>глЗначениеПеременной(«глТекущийПользователь»), «ОсновнаяОрганизация»);

    {ОбщийМодуль.ОбщегоНазначения.Модуль(6219,20)}: Процедура или функция с указанным именем не определена (глЗначениеПеременной)

    УчетнаяПолитика = <<?>>глЗначениеПеременной(«глУчетнаяПолитика»);

    {ОбщийМодуль.ОбщегоНазначения.Модуль(8521,8)}: Процедура или функция с указанным именем не определена (глЗначениеПеременной)

    Если <<?>>глЗначениеПеременной(«ИспользоватьУправляемыеБлокировки») Тогда

    Reply ↓
  27. morozov.sv

    (26) Напишите, пожалуйста, релиз

    Reply ↓
  28. morozov.sv

    (26) Есть подозрение, что ошибка относиться к другой публикации. Не вижу Ваш ник среди скачавших и в моей такого кода не нашел…

    Проверьте, пожалуйста

    Reply ↓
  29. Castlevania

    Автор ошибку не исправил. Просто так потратили 7 стартмани. В итоге скачали у другого автора аналогичную, но работающую обработку

    Reply ↓
  30. morozov.sv

    (29) Чтобы исправить ошибку нужно смоделировать аналогичную ситуацию у себя на компьютере. Я проверил работу обработки на типовой конфигурации Бухгалтерии 2.0 вашего релиза в разных режимах, но проблемная ситуация не возникла. Поэтому попросил Вас указать настройки, с которыми вы ее запускали. К сожалению, ответа не было. Без этой информации исправить проблему не получится

    Reply ↓

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *