Поздравлялка с 8 марта




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2018-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

29 Comments

  1. JokerIV

    Не работает на 8.1

    Reply
  2. Tatitutu

    Хороший комментарий 😀

    Обработку выложил на вражеском сайте

    Reply
  3. v.l.

    (1) Теперь работает. Добавил файл для 8.1, пришлось назад копипастить из 8.2 в 8.1

    Reply
  4. v.l.

    (2) Угу, попробуй там написать «инфостарт» — матофильтр сработает.

    Reply
  5. iov

    (4) именно суровая действительность и отсутствие логики порой приводят к причудливым формам уродства. Что мы и наблюдаем в данном примере

    Reply
  6. rsu555

    в 8.2 запускаю ошибка файловой операции ‘D:ДанныеОбработки82.epf’

    по причине:

    Неверный формат хранилища данных ‘file://D:/Данные/Обработки/82.epf’

    Reply
  7. v.l.

    (6) странно. Я из своей рабочей базы сохранил.

    Может, управляемое приложение?

    Когда дочитаю Радченко 8.2 до нужного места, возможно, перепишу под управляемое приложение.

    Reply
  8. v.l.

    (7) Вот, нашел рекомендации:

    — В свойствах конфигурации установить галочку «использовать обычные формы в управляемом приложении»

    — обработка должна быть интегрирована в конфигурацию (а не быть внешней обработкой)

    — предприятие должно быть запущенно в режиме толстого клиента.

    Reply
  9. rsu555
    vladal пишет:

    (6) странно. Я из своей рабочей базы сохранил.

    Может, управляемое приложение?

    Когда дочитаю Радченко 8.2 до нужного места, возможно, перепишу под управляемое приложение.

    нет это я лопухнулся.. без расширения файл, вот я и подумал что это обработка, а оказался архив, в котором обработка..все работает спасибо

    Reply
  10. v.l.

    (9) Вот и хорошо. Только для 8.2 я еще упаковал 7zip, выиграл 100 килобайт.

    Это он так сохранился без расширения?

    Reply
  11. v.l.

    (2) Кстати, вон девушка тоже столкнулась с подобным:

    http://www.forum.mista.ru/topic.php?id=536396#11

    Reply
  12. Сисой

    Автору не кажется, что сжимать обработку для 1С 8 в формате 7z — извращение?

    Может, стоит использовать более привычные большинству пользователей форматы?

    Reply
  13. v.l.

    (12) нет, автору так не кажется.

    Я им лет 5 пользуюсь — он бесплатен, хорошо жмёт в своем формате, лучше РАР и ЗИП, мультиязычен, встраивается в проводник.

    Если надо — перезалью не сжатый. Если найду быстро 😉

    Reply
  14. finik1

    Спасибо! Всех поздравил!

    Reply
  15. Abadonna

    (10)

    Только для 8.2 я еще упаковал 7zip, выиграл 100 килобайт.

    А копейку уронишь — нагибаешься её поднять? 😉

    Reply
  16. z-alexey

    >P.S. За идею с картинками благодарю Sirruf (http://infostart.ru/public/82288/)

    а ссылка на свою же обработку 🙂

    Reply
  17. v.l.

    (15)

    А копейку уронишь — нагибаешься её поднять?

    И таки да, а шобы и нет?

    Reply
  18. v.l.

    (16) Упс… что было в буфере… Спасибо, поправил.

    Reply
  19. axelload

    Скачал, пользуюсь, радуюсь 🙂

    Reply
  20. v.l.

    (19) И шо, уже 8 марта? )))

    Reply
  21. Sanek_159

    (20) Готовит сани с лета =). И я вот начинаю в предверии праздника подготовку.

    Reply
  22. Master07

    Спасибо! Актуально перед празжничком!

    Reply
  23. AndreyMurom

    Спасибо большое, надо поздравить девчонок с праздником.

    Reply
  24. AndreyMurom

    А можете кто-нибудь подсказать, что можно дописать, чтобы обработка запускалась в развернутом виде?

    Reply
  25. v.l.

    (24) Я задумывал, как модальное окно. Развернуть можно программно, а можно и свойствами формы — Способ отображения окна = Максимизированное.

    Reply
  26. v.l.

    Только что допилил модуль приложения, процедуру ПриНачалеРаботыСистемы()

     // ВЛ — 2012-03-06 — Поздравлялка с 8 марта
    ТекМесяц = Месяц(Текущаядата());
    ТекДень = День(ТекущаяДата());
    Если ТекМесяц = 3 Тогда
    
    // Мурррт!
    Если ТекДень >= 6 И ТекДень <= 8 Тогда
    
    // Отвосьмимартим
    Пол = ПараметрыСеанса.ТекущийПользователь.ФизЛицо.Пол;
    Если Пол = Перечисления.ПолФизическихЛиц.Женский Тогда
    
    Поздравлялка8Марта = Обработки.Поздравлялка8марта.ПолучитьФорму();
    Поздравлялка8Марта.Открыть();
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры // ПриНачалеРаботыСистемы()
    

    Показать

    Reply
  27. Oleg1708

    Вот бухов обрадуют… 🙂

    Reply
  28. wunderland

    а тем кто под 7.7 спину гнет так и сидеть без поздравления?

    Reply
  29. v.l.

    (28) wunderland, ну почему же? Есть несколько просмотрщиков.

    И зачем сидеть без поздравления?

    Можешь написать сам или помочь?

    Reply

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *