Восстанавливаем штрих-код (7.7)




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2018-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

7 Comments

  1. awk

    За алгоритм — плюс, за форматирование кода — минус. Пока не переписал в виде:

    Функция ВосстановитьEAN13(пКод)
    ДлинаКода = СтрДлина(пКод);
    Если ДлинаКода = 13 Тогда
    Возврат пКод;
    ИначеЕсли ДлинаКода < 12 Тогда
    Возврат «»;
    Иначе
    ДесятьПервых = Лев(пКод,10);
    Для й = 0 по 9 Цикл
    ШтрКод = Строка(й) + ДесятьПервых;
    СуммаЧетныхЧиселВКоде = 0;
    СуммаНечетныхЧиселВКоде = 0;
    Для Индекс = 1 По 6 Цикл
    СуммаЧетныхЧиселВКоде = СуммаЧетныхЧиселВКоде + Сред(ШтрКод, 2 * Индекс, 1);
    СуммаНечетныхЧиселВКоде = СуммаНечетныхЧиселВКоде + Сред(ШтрКод, 2 * Индекс — 1, 1);
    КонецЦикла;
    КонтрольнаяСумма = 10 — (СуммаЧетныхЧиселВКоде * 3 + СуммаНечетныхЧиселВКоде) % 10;
    КонтрольнаяСумма = ?(КонтрольнаяСумма = 10, «0», Строка(КонтрольнаяСумма));
    Если Прав(пКод,1) = КонтрольнаяСумма Тогда
    Возврат ШтрКод + КонтрольнаяСумма;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    Возврат «»;
    КонецФункции //ВосстановитьEAN13

    Показать

    алгоритм не понял…

    Reply
  2. awk

    (0) А вот так будет ещё и быстрее работать, за счет уменьшения количества операций:

    Функция ВосстановитьEAN13(пКод)
    ДлинаКода = СтрДлина(пКод);
    Если ДлинаКода = 13 Тогда
    Возврат пКод;
    ИначеЕсли ДлинаКода < 12 Тогда
    Возврат «»;
    Иначе
    ДесятьПервых = Лев(пКод,10);
    СуммаЧетныхЧиселВКоде = 0;
    СуммаНечетныхЧиселВКоде = 0;
    Для Индекс = 1 По 6 Цикл
    СуммаЧетныхЧиселВКоде = СуммаЧетныхЧиселВКоде + Сред(ШтрКод, 2 * Индекс — 1, 1);
    СуммаНечетныхЧиселВКоде = СуммаНечетныхЧиселВКоде + Сред(ШтрКод, 2 * Индекс, 1);
    КонецЦикла;
    // Подбор
    Для й = 0 по 9 Цикл
    КонтрольнаяСумма = 10 — (СуммаЧетныхЧиселВКоде * 3 + СуммаНечетныхЧиселВКоде + й) % 10;
    КонтрольнаяСумма = ?(КонтрольнаяСумма = 10, «0», Строка(КонтрольнаяСумма));
    Если Прав(пКод,1) = КонтрольнаяСумма Тогда
    Возврат Строка(й) + ДесятьПервых + КонтрольнаяСумма;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    Возврат «»;
    КонецФункции //ВосстановитьEAN13

    Показать

    Reply
  3. Арчибальд

    (1) Вот этот кусочек

       Четн = 0;
    Нечетн = 0;
    Для Индекс = 1 По 6 Цикл
    Четн = Четн + Сред(ШтрКод, 2 * Индекс, 1);
    Нечетн = Нечетн + Сред(ШтрКод, 2 * Индекс — 1, 1);
    КонецЦикла;
    Четн = Четн * 3;
    КонтЦифра = 10 — (Четн + Нечетн) % 10;

    Взят прямо из стандартной конфы копипастом 😐

    Reply
  4. awk

    (3) Не боги горшки обжигают… Странно, но раньше в этой поговорке я видел другой смысл… 🙂 Я просто был удивлен, что такой специалист, пишет такой код. Вы меня успокоили. А по поводу стандартных конфигураций… У меня иногда волосы встают дыбом — когда вижу их код… А особенно когда вижу комменты… Функция была прокомментирована в стандартной бухгалтерии 8. Списание партий по методу ФИФО. Как она списывала, я так и не понял (ни ФИФО, ни ЛИФО, ни по среднему там и рядом не лежало, а то бы не полез)… Просто переписал… Код функции сократился вдвое…

    Reply
  5. Арчибальд

    (4) Но ДесятьПервых — это таки Одинадцать 😮

    А боги не обжигают горшки потому, что боятся лажануться 😀

    Reply
  6. awk

    (5) Ух.. да… Вот и польза читабельности кода…

    Reply
  7. awk

    (0) По моему статья с комментариями — получилась наглядным пособием «Для чего читабельность нужна…». Хоть оформляй как отдельную тему… А то новички (по себе знаю) форматирование кода отрицают. Типа мол я же читаю свой код… И чем менее понятно напишут, тем круче себя считают…

    Reply

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *