Настройка принтеров




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2018-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

10 Comments

  1. vcv

    Если обработка предназначена для пользователей без рабочего стола, то зачем им «Создать ярлык», удалить, переименовать, свойства и прочее? Открыть, настройки печати, Выбрать по умолчанию. И хватит.

    Reply
  2. pophmail

    Ещё «Отменить печать» или «Очистить очередь печати» востребовано иногда…

    Reply
  3. Umix

    По просьбе vcv доработано. По поводу очистки очереди печати попробую изыскать способ, ибо перебор пунктов меню (скриптовой) такового не имеет((

    Reply
  4. Umix

    (1) vcv, видел у тебя похожую штуку)). А то пылятся некоторые удобняжки годами, пусть народ пользуется.

    Reply
  5. vcv

    (4) Ни что не ново под луной. Все мы тут бояншики и велосипедисты.

    Reply
  6. Umix

    зато движемся вперед))

    Reply
  7. Umix

    (2) pophmail, кое-что подтянул.

    Reply
  8. pophmail

    Перезапускать спулер, в этом случае, не совсем хорошо, кроме того принтеры могут быть подключены к другим ПК (права на отмену) или к принтсерверу (встроенному) а задания могут полностью или частично находится уже в их памяти…

    Я когда то сделал так, хотя конечно некоторые задания отменить не выйдет:

    Процедура глОтменитьПечать(пред) Экспорт

    скрипт=createobject(«MSScriptControl.ScriptControl»);

    скрипт.language=»vbscript»;

    скрипт.addcode(»

    |Function CancelAllJobs()

    |Jobs=0

    |zp=vbNullString

    |nameP=vbNullString

    |Set objWMIService=GetObject(«»winmgmts:»» _

    |& «»{impersonationLevel=impersonate}!\.
    ootcimv2″»)

    |Set colInstalledPrinters=objWMIService.ExecQuery _

    |(«»Select * from Win32_Printer»»)

    |For Each objPrinter in colInstalledPrinters

    |If objPrinter.PrinterStatus<>3 Then

    |Jobs=Jobs+1

    |If Jobs=1 Then zp=vbNullString Else zp=Chr(44) End If

    |nameP=nameP+zp+Chr(34)+objPrinter.Name+Chr(34)

    |End If

    |objPrinter.CancelAllJobs()

    |Next

    |CancelAllJobs=nameP

    |End Function»);

    СписокПринтеровСЗаданиями=скрипт.run(«CancelAllJobs»);

    Если пред=1

    Тогда

    сп=СоздатьОбъект(«СписокЗначений»);

    сп.ИзСтрокиСРазделителями(СписокПринтеровСЗаданиями);

    Зад=0;

    Для ы=1 по сп.РазмерСписка()

    Цикл

    ИмяПринтера=сп.ПолучитьЗначение(ы);

    Если ПустоеЗначение(ИмяПринтера)=0

    Тогда

    Зад=Зад+1;

    КонецЕсли;

    КонецЦикла;

    Если Зад>0

    Тогда

    Если Вопрос(«Отменены задания для принтеров:

    |»+СписокПринтеровСЗаданиями+»

    |Показать очередь печати?»,»Да+Нет»)=»Да»

    Тогда

    WSH=СоздатьОбъект(«WScript.Shell»);

    Для ы=1 по сп.РазмерСписка()

    Цикл

    ИмяПринтера=сп.ПолучитьЗначение(ы);

    Если ПустоеЗначение(ИмяПринтера)=0

    Тогда

    WSH.Run(«rundll32 printui.dll, PrintUIEntry /o /n «+симв(34)+ИмяПринтера+симв(34),1,1);

    КонецЕсли;

    КонецЦикла;

    КонецЕсли;

    Иначе

    Предупреждение(«Нет заданий на печать.»,10);

    КонецЕсли;

    КонецЕсли;

    КонецПроцедуры

    Reply
  9. Umix

    (8) pophmail, вы правы (в публикации это тоже подчеркивается) очищать спулер на серваке решение не супер (для локального принтера если только)

    Однако, читал, что использование «rundll32 printui.dll, PrintUIEntry» тоже не всегда срабатывает((

    Все-таки думаю, применение Prnqctl.vbs будет предпочтительнее, хотя не совсем уверен.

    … опять же хочется дотянуться до функции «очистить очередь печати» более простым способом через коллекцию свойств и функций (new Enumerator()), хотя может такого нет по природе и снова изобретаем велосипед(((

    Reply
  10. pophmail

    (9) если бы велосипеды не совершенствовали «изобретатели» — и сейчас они были бы с деревянными колёсами и рамой как самый первый ;-)…

    Reply

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *