Получение времени с точностью до миллисекунд в 8.х




Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.
PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

В продолжение моей темы: 1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом.
С помощью данного скрипта можно загружать в автоматическом режиме, по расписанию, данные сервисных книжек (ремонтов авто) из 1С:Альфа-Авто Автосалон Автосервис.
Также можно загружать данные в ручном режиме: для этого делается скрытая страница, где размещается специальная кнопка.
Комментарии размещенные внутри скрипта разъяснят логику и порядок действия.
Комментарии с "/////    echo" использовались для отладки.
Дополнительно создана таблица для журналирования результатов загрузки данных.
Скрипт включает в себя защиту от SQL инъекций (думаю безопасность соблюдена в полной мере).
В кратце:
1. Пишется скрипт, который запускает этот.
2. Создается регламентное задание в WordPress, по которому запускается скрипт из п.1. 
3. Этот скрипт осуществляет проверку на существование файла обмена в папке.
4. Если данные не новые, загрузка не производится.
5. Если данные новые, очищается таблица сервисных книжек.
6. Загружаются новые данные.

Собственно сам скрипт:

<?php // Полная загрузка сервисных книжек, создан 2018-01-05 12:44:55

global $wpdb2;
global $failure;
global $file_hist;

/////  echo '<H2><b>Старт загрузки</b></H2><br>';

$failure=FALSE;
//подключаемся к базе
$wpdb2 = include_once 'connection.php'; ; // подключаемся к MySQL
// если не удалось подключиться, и нужно оборвать PHP с сообщением об этой ошибке
if (!empty($wpdb2->error))
{
/////   echo '<H2><b>Ошибка подключения к БД, завершение.</b></H2><br>';
$failure=TRUE;
wp_die( $wpdb2->error );
}

$m_size_file=0;
$m_mtime_file=0;
$m_comment='';
/////проверка существования файлов выгрузки из 1С
////файл выгрузки сервисных книжек
$file_hist = ABSPATH.'/_1c_alfa_exchange/AA_hist.csv';
if (!file_exists($file_hist))
{
/////   echo '<H2><b>Файл обмена с сервисными книжками не существует.</b></H2><br>';
$m_comment='Файл обмена с сервисными книжками не существует';
$failure=TRUE;
}

/////инициируем таблицу лога
/////если не существует файла то возврат и ничего не делаем
if ($failure){
///включает защиту от SQL инъекций и данные можно передавать как есть, например: $_GET['foo']
/////   echo '<H2><b>Попытка вставить запись в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>$m_comment));
wp_die();
/////    echo '<H2><b>Возврат в начало.</b></H2><br>';
return $failure;
}
/////проверка лога загрузки, что бы не загружать тоже самое
$masiv_data_file=stat($file_hist);   ////передаем в массив свойство файла
$m_size_file=$masiv_data_file[7];    ////получаем размер файла
$m_mtime_file=$masiv_data_file[9];   ////получаем дату модификации файла
////создаем запрос на получение последней удачной загрузки
////выбираем по штампу времени создания (редактирования) файла загрузки AA_hist.csv, $m_mtime_file

/////   echo '<H2><b>Размер файла: '.$m_size_file.'</b></H2><br>';
/////   echo '<H2><b>Штамп времени файла: '.$m_mtime_file.'</b></H2><br>';
/////   echo '<H2><b>Формирование запроса на выборку из лога</b></H2><br>';
////препарируем запрос
$text_zaprosa=$wpdb2->prepare("SELECT * FROM `vin_logs` WHERE `last_mtime_upload` = %s", $m_mtime_file);
$results=$wpdb2->get_results($text_zaprosa);

if ($results)
{   foreach ( $results as $r)
{
////если штамп времени и размер файла совпадают, возврат
if (($r->last_mtime_upload==$m_mtime_file) && ($r->last_size_upload==$m_size_file))
{////echo '<H2><b>Возврат в начало, т.к. найдена запись в логе.</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>$m_mtime_file,'last_size_upload'=>$m_size_file,'comment'=>'Загрузка отменена, новых данных нет, т.к. найдена запись в логе.'));
wp_die();
return $failure;
}
}
}
////если данные новые, пишем в лог запись о начале загрузки
/////echo '<H2><b>Попытка вставить запись о начале загрузки в лог таблицу</b></H2><br>';
$insert_fail_zapros=$wpdb2->insert('vin_logs', array('time_stamp'=>time(),'last_mtime_upload'=>0, 'last_size_upload'=>$m_size_file, 'comment'=>'Начало загрузки'));

////очищаем таблицу
$clear_tbl_zap=$wpdb2->prepare("TRUNCATE TABLE %s", 'vin_history');
$clear_tbl_zap_repl=str_replace("'","`",$clear_tbl_zap);
$results=$wpdb2->query($clear_tbl_zap_repl);
/////   echo '<H2><b>Очистка таблицы сервисных книжек</b></H2><br>';
if (empty($results))
{
/////   echo '<H2><b>Ошибка очистки таблицы книжек, завершение.</b></H2><br>';
//// если очистка не удалась, возврат
$failure=TRUE;
wp_die();
return $failure;
}

////загружаем данные
$table='vin_history';         // Имя таблицы для импорта
//$file_hist Имя CSV файла, откуда берется информация     // (путь от корня web-сервера)
$delim=';';          // Разделитель полей в CSV файле
$enclosed='"';      // Кавычки для содержимого полей
$escaped='\

12 Comments

  1. Evg-Lylyk

    Простенько :).

    Для замеров лучше использовать

    Функция ТекущееВремяВМс() Экспорт

    //Получаем время в м/с через скрипт

    Script.Language = «javascript»;

    Счетчик = Script.eval(«new Date().getTime()»);

    Возврат Счетчик;

    КонецФункции

    //—————

    НачалоЗамера = ТекущееВремяВМс();

    //—

    <Код>

    //—

    //——-КонецЗамера

    ПрошлоМс = ТекущееВремяВМс() — НачалоЗамера;

    Reply
  2. German

    Сложно

    Reply
  3. ValeriVP

    (2)знаешь как проще?

    Reply
  4. kadr

    (1) уже давненько используется в Enterprise Integrator

    Reply
  5. Evg-Lylyk

    (4) не знал. Я в стандарной консоли отчетов 1с подсмотрел.

    Reply
  6. eugeniezheludkov

    почитал скрипт и вправду замутный и незачем так изголяться … да еще и минус у него есть MSScriptControl не на всех серверах установлен а значит есть вероятность падения базы если админов не потормошить 🙁

    есть еще как минимум 2 варианта работающих на любом сервере это через Wbem и .Net но это все не то ..

    Reply
  7. ValeriVP

    (6)МоментВремени() — не содержит миллисекунд. Он содержит только время до секунд и уникальный идентификатор документа.

    Reply
  8. eugeniezheludkov

    да уже прочитал только что понял что всегда ошибался полагая что можно…спасибо.

    пс: что нужно установить на сервере «файл.ехе» чтоб MSScriptControl зарегистрировать ? админа тереблю тот тоже не сном не духом

    у мня ошибка : {ОбщийМодуль.Math_and_Server.Модуль(25)}: Ошибка при вызове конструктора (COMОбъект): Класс не зарегистрирован Скрипт = Новый COMОбъект(«MSScriptControl.ScriptControl»);

    Reply
  9. ValeriVP

    (8)если сервер win64, то: http://infostart.ru/public/69986/

    Reply
  10. eugeniezheludkov

    недождавшись ответа использовал этот метод который работает помоему на всех серверах:

    Функция ТекущаяДатаМилисекунды() Экспорт

    Locator = Новый COMОбъект(«WbemScripting.SWbemLocator»);

    ServicesSet = Locator.ConnectServer(«.»);

    pEnum = ServicesSet.InstancesOf(«Win32_OperatingSystem»);

    Для каждого Object Из pEnum Цикл

    Возврат сред(Object.LocalDateTime,1,20);

    КонецЦикла;

    Возврат 0;

    //Скрипт = Новый COMОбъект(«MSScriptControl.ScriptControl»);

    //Скрипт.language = «javascript»;

    //Возврат Формат(Скрипт.eval(«new Date().getTime()»),»ЧГ=0″)/1000;

    КонецФункции

    Reply
  11. wiz911

    ТекущаяУниверсальнаяДатаВМиллисекундах() c 8.2

    И никаких выдумок )

    Reply
  12. agent00mouse

    (11)

    ТекущаяУниверсальнаяДатаВМиллисекундах

    Спасибо, актуально.

    Reply

Leave a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *